Improve our spell checker offering on Mac

Francesco Lodolo [:flod] flod at lodolo.net
Sat Dec 24 07:47:43 UTC 2016


Hi Tim,
I might be wrong, but it sounds like you're complaining about the 
functionality (Hunspell support) when the problem is actually with the 
dictionary you're using (not sure if the default one, or another English).

For example 'cesee' is correctly marked as an error for me with
https://addons.mozilla.org/en-US/firefox/addon/united-states-english-spellche/

Francesco

[1] 
https://hg.mozilla.org/mozilla-central/log/default/extensions/spellcheck/locales/en-US/hunspell/en-US.dic
> I've find the first one after I decided to intentionally collect them. 
> Will put them here:
>
> https://public.etherpad-mozilla.org/p/humspell-v-s-osxspell
>
> On Sat, Dec 24, 2016 at 2:11 PM, Tim Guan-tin Chien 
> <timdream at mozilla.com <mailto:timdream at mozilla.com>> wrote:
>
>     English. Hunspell couldn't find the correct spellings from many of
>     my my bad spellings where OSX spell could.
>
>     I am sorry that I couldn't give example at hand since Alfred
>     doesn't keep a long history of what's being typed.
>
>     On Fri, Dec 23, 2016 at 10:14 PM, Ehsan Akhgari
>     <ehsan.akhgari at gmail.com <mailto:ehsan.akhgari at gmail.com>> wrote:
>
>         What is the concrete problem with Hunspell?  Is it missing
>         words?  What language are you spell checking?
>
>         On Fri, Dec 23, 2016 at 2:00 AM, Tim Guan-tin Chien
>         <timdream at mozilla.com <mailto:timdream at mozilla.com>> wrote:
>
>             I am consistently burned by our own hunspell and I found
>             myself copy-and-paste words to Alfred all the time just to
>             get the right spelling from osxspell. I am not sure if we
>             have any studies on this (and maybe put our spell checker
>             onto the "great or dead" track).
>
>             This is the five digit bug to work on if we want to
>             address it:
>             https://bugzilla.mozilla.org/show_bug.cgi?id=86886
>             <https://bugzilla.mozilla.org/show_bug.cgi?id=86886>
>
>             _______________________________________________
>             firefox-dev mailing list
>             firefox-dev at mozilla.org <mailto:firefox-dev at mozilla.org>
>             https://mail.mozilla.org/listinfo/firefox-dev
>             <https://mail.mozilla.org/listinfo/firefox-dev>
>
>
>
>
>         -- 
>         Ehsan
>
>
>
>
>
> _______________________________________________
> firefox-dev mailing list
> firefox-dev at mozilla.org
> https://mail.mozilla.org/listinfo/firefox-dev

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.mozilla.org/pipermail/firefox-dev/attachments/20161224/4cc285d8/attachment.html>


More information about the firefox-dev mailing list