Python 2.7.3 now required to build

Gregory Szorc gps at mozilla.com
Wed Sep 18 18:28:29 UTC 2013


This was backed out a few days after it landed because it was disrupting 
the Oslo B2G work.

It just landed in inbound again.

|mach bootstrap| is now more intelligent about detecting $PATH issues 
and telling you how to install a modern Python. While OS X should "just 
work," some manual work may be required elsewhere.

As a friendly reminder, bootstrap support is best effort. Patches to 
make it "just work" are more than welcome and will be swiftly reviewed 
if they appear on my review queue. File under Core :: Build Config.

On 9/5/13 2:25 PM, Gregory Szorc wrote:
> Just landed in inbound and making its way to a tree near you is the
> requirement that you use Python 2.7.3 or greater (but not Python 3) to
> build the tree. If you see any issues, bug 870420 is responsible.
> Previously we required Python 2.7.0 or greater. This change has been
> planned and agreed to for months and was recently unblocked to land.
>
> Hopefully things should "just work" for most people. MozillaBuild
> (Windows dev environment) is shipping Python 2.7.5 and most Linux
> distros are running 2.7.3+. OS X, however, lags. OS X 10.8 ships 2.7.2,
> so attempting to build out of the box will give you an error.
>
> If your Python is too old, the build system will instruct you what to
> do. For most people, run `mach bootstrap` and it will hopefully install
> a modern Python on your machine. If that doesn't work, patches welcome
> (code in /python/mozboot).
> _______________________________________________
> firefox-dev mailing list
> firefox-dev at mozilla.org
> https://mail.mozilla.org/listinfo/firefox-dev




More information about the firefox-dev mailing list