Python 2.7.3 now required to build

Gregory Szorc gps at mozilla.com
Thu Sep 5 21:25:54 UTC 2013


Just landed in inbound and making its way to a tree near you is the 
requirement that you use Python 2.7.3 or greater (but not Python 3) to 
build the tree. If you see any issues, bug 870420 is responsible.
Previously we required Python 2.7.0 or greater. This change has been 
planned and agreed to for months and was recently unblocked to land.

Hopefully things should "just work" for most people. MozillaBuild 
(Windows dev environment) is shipping Python 2.7.5 and most Linux 
distros are running 2.7.3+. OS X, however, lags. OS X 10.8 ships 2.7.2, 
so attempting to build out of the box will give you an error.

If your Python is too old, the build system will instruct you what to 
do. For most people, run `mach bootstrap` and it will hopefully install 
a modern Python on your machine. If that doesn't work, patches welcome 
(code in /python/mozboot).



More information about the firefox-dev mailing list